front_matter 1.1.0
front_matter: ^1.1.0

Dart native
Flutter Android iOS

A front matter parser that extracts YAML metadata from the start of a file or string.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  front_matter: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:front_matter/front_matter.dart';
2
likes
100
pub points
66%
popularity

A front matter parser that extracts YAML metadata from the start of a file or string.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

izolate@gmail.com

License

MIT (LICENSE)

Dependencies

yaml

More

Packages that depend on front_matter