fountainview 1.0.5

Flutter Android iOS

Flutter Plugin for viewing Fountain markup documents on Android and iOS.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/xamarin/mobcat/tree/FountainView/scratch/flutter/FountainView was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 5 API elements (20.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:fountainview/fountainview.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:fountainview/fountainview.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:fountainview/fountainview.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:fountainview/fountainview.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_html^0.9.40.9.91.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
csslib-0.16.20.16.2
html-0.14.0+40.14.0+4
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
path-1.7.01.7.0
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.4` on flutter_html does not support the latest published version `1.0.2`

pubspec.yaml:14:17

   ╷
14 │   flutter_html: ^0.9.4
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

Flutter Plugin for viewing Fountain markup documents on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

benbtg@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_html

More

Packages that depend on fountainview