fortnite_api_io 1.0.0 copy "fortnite_api_io: ^1.0.0" to clipboard
fortnite_api_io: ^1.0.0 copied to clipboard

An api wrapper for https://fortniteapi.io in dart.

1
likes
120/ 140
pub points
10%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

94 out of 96 API elements (97.9 %) have documentation comments.

Some symbols that are missing documentation: fortnite_api_io, fortnite_api_io.FortniteApiIo.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.4 4.0.6 5.4.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.4` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1
likes
120
pub points
10%
popularity

Publisher

verified publishervanxh.dev

An api wrapper for https://fortniteapi.io in dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

dio

More

Packages that depend on fortnite_api_io