fortnite_api 0.0.1
fortnite_api: ^0.0.1 copied to clipboard

Fortnite Api Wrapper.

1
likes
65 / 130
pub points
0 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/andrevarandas/dart-fortnite-api-wrapper/compare/v0.0.1">v0.0.1</a> - 2020-10-06</h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 333 API elements (3.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

lib/api/accounts/data/all.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/api/accounts/data/player_account.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.13.3
json_annotation^3.1.03.1.14.1.0
meta^1.2.31.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.1.0` on json_annotation does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.4.