fortnite 1.3.21 copy "fortnite: ^1.3.21" to clipboard
fortnite: ^1.3.21 copied to clipboard

A fortnite api manager library in dart. This library allows you to easily communicate with fortnite api and manage your account.

4
likes
120/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

839 out of 966 API elements (86.9 %) have documentation comments.

Some symbols that are missing documentation: account_resources, account_resources.accountResources, auth_clients, base_item_rating, base_item_rating.baseItemRatingCurveTable.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Dangling library doc comment.

lib/resources/storm_king_quests.dart:1:1

  ╷
1 │ /// A class representing storm king quest
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/resources/storm_king_quests.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.4 4.0.6 5.4.1
logging ^1.0.2 1.2.0 1.2.0
numeral ^1.2.5 1.2.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.4` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^1.2.5` on numeral does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions numeral to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

4
likes
120
pub points
0%
popularity

Publisher

verified publishervanxh.dev

A fortnite api manager library in dart. This library allows you to easily communicate with fortnite api and manage your account.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

dio, logging, numeral

More

Packages that depend on fortnite