forestvpn_auth_api 1.0.2
forestvpn_auth_api: ^1.0.2 copied to clipboard

Dart native js
Flutter Android iOS web

A package to interact auth.forestvpn.com (registration, authentication, bearer tokens, ...)

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Feb 24, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.forestvpn.com/ was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 295 API elements (10.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 147 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/api/auth_api.dart:38:9

   ╷
38 │         postBody = mp;
   │         ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/api/auth_api.dart

INFO: DO use curly braces for all flow control structures.

lib/api/auth_api.dart:96:9

   ╷
96 │         postBody = mp;
   │         ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/api/auth_api.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http>=0.12.0 <0.13.00.12.20.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.10.01.10.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.12.0 <0.13.0` on http does not support the latest published version `0.13.0`

pubspec.yaml:10:9

   ╷
10 │   http: '>=0.12.0 <0.13.0'
   │         ^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.12.0-133.2.beta.

0
likes
60
pub points
0%
popularity

Publisher

forestvpn.com

A package to interact auth.forestvpn.com (registration, authentication, bearer tokens, ...)

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http

More

Packages that depend on forestvpn_auth_api