forcemvc2 0.4.1
forcemvc2: ^0.4.1 copied to clipboard

Dart native

A serverside web mvc framework with templates (ported to Dart 2 by Ross Albertson)

1
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Feb 20, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 137 out of 504 API elements (27.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:forcemvc2/forcemvc2.dart that imports:
  • package:wired2/wired2.dart that imports:
  • package:mirrorme2/mirrorme2.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 387 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/annotations/helpers.dart:6:9

  ╷
6 │         new AnnotationScanner<_Authentication>();
  │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/annotations/helpers.dart

INFO: Unnecessary new keyword.

lib/annotations/helpers.dart:12:9

   ╷
12 │         new AnnotationScanner<_Authentication>();
   │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/annotations/helpers.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http_server>=0.9.0 <0.10.00.9.8+30.9.8+3
intl^0.16.00.16.10.17.0
locales^0.1.00.1.00.1.0
logging>=0.11.0 <0.12.00.11.41.0.0
mirrorme2^0.1.00.1.00.1.0
mockito^4.0.04.1.44.1.4
mustache4dart2^0.1.00.1.00.1.0
path^1.6.21.8.01.8.0
route2^0.1.10.1.10.1.1
wired2^0.1.00.1.00.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.016.0.0
analyzer-0.41.21.0.0
args-2.0.02.0.0
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
build-1.6.21.6.3
built_collection-5.0.05.0.0
built_value-8.0.08.0.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
code_builder-3.6.03.6.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.03.0.0
dart_style-1.3.121.3.13
file-6.1.06.1.0
fixnum-1.0.01.0.0
glob-2.0.02.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-0.9.71.0.0
package_config-1.9.32.0.0
pedantic-1.10.01.10.0
pub_semver-2.0.02.0.0
source_gen-0.9.10+30.9.10+3
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.2.190.2.19
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-2.2.13.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.0` on intl does not support the latest published version `0.17.0`

pubspec.yaml:22:9

   ╷
22 │   intl: ^0.16.0
   │         ^^^^^^^
   ╵
The constraint `>=0.11.0 <0.12.0` on logging does not support the latest published version `1.0.0`

pubspec.yaml:9:12

  ╷
9 │   logging: '>=0.11.0 <0.12.0'
  │            ^^^^^^^^^^^^^^^^^^
  ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.12.0-133.2.beta.

1
likes
60
pub points
0%
popularity

A serverside web mvc framework with templates (ported to Dart 2 by Ross Albertson)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ozonesurfer68@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

http_server, intl, locales, logging, mirrorme2, mockito, mustache4dart2, path, route2, wired2

More

Packages that depend on forcemvc2