fontgraphy 1.0.1
fontgraphy: ^1.0.1

Flutter Android iOS

A package to include fonts from fontgraphy.ir in your Flutter app.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 94 out of 97 API elements (96.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:fontgraphy/fontgraphy.dart that imports:
  • package:fontgraphy/src/fontgraphy_base.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 901 issues. Showing the first 2:

INFO: 'display4' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline1. This feature was deprecated after v1.13.8..

lib/fontgraphy.dart:308:7

    ╷
308 │       display4: Fontgraphy.badr(textStyle: textTheme?.display4),
    │       ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/fontgraphy.dart

INFO: 'display4' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline1. This feature was deprecated after v1.13.8..

lib/fontgraphy.dart:308:55

    ╷
308 │       display4: Fontgraphy.badr(textStyle: textTheme?.display4),
    │                                                       ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/fontgraphy.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.52.1.5
http^0.12.0+20.12.20.12.2
path_provider^1.4.01.6.241.6.24
pedantic^1.8.01.9.21.9.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

A package to include fonts from fontgraphy.ir in your Flutter app.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

sahandevs@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

crypto, flutter, http, path_provider, pedantic

More

Packages that depend on fontgraphy