folly_fields 0.17.4 icon indicating copy to clipboard operation
folly_fields: ^0.17.4 copied to clipboard

Basic form fields and utilities.

3
likes
100/ 140
pub points
71%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 1718 API elements (0.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:folly_fields/folly_fields.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:folly_fields/folly_fields.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:folly_fields/folly_fields.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:folly_fields/folly_fields.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:folly_fields/folly_fields.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: 'subtitle1' is deprecated and shouldn't be used. Use titleMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/fields/bool_field.dart:82:51

   ╷
82 │                 Theme.of(field.context).textTheme.subtitle1!.color;
   │                                                   ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fields/bool_field.dart

INFO: 'subtitle1' is deprecated and shouldn't be used. Use titleMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/fields/bool_field.dart:85:51

   ╷
85 │                 Theme.of(field.context).textTheme.subtitle1!.copyWith(
   │                                                   ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fields/bool_field.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_plus^3.0.03.0.23.0.2
cpf_cnpj_validator^2.0.02.0.02.0.0
dial_picker^1.0.11.0.1+11.0.1+1
email_validator^2.1.172.1.172.1.17
expandable^5.0.15.0.15.0.1
file_picker^5.2.25.2.55.2.5
flutterflutter0.0.00.0.0
flutter_colorpicker^1.0.21.0.31.0.3
flutter_localizationsflutter0.0.00.0.0
font_awesome_flutter^10.3.010.3.010.3.0
intl^0.17.00.17.00.18.0
sprintf^7.0.07.0.07.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.22.3.2
async-2.10.02.10.0
boolean_selector-2.1.12.1.1
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.17.01.17.1
connectivity_plus_platform_interface-1.2.31.2.3
cupertino_icons-1.0.51.0.5
dbus-0.7.80.7.8
fake_async-1.3.11.3.1
ffi-2.0.12.0.1
flutter_plugin_android_lifecycle-2.0.72.0.7
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
js-0.6.50.6.7
matcher-0.12.130.12.14
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
nm-0.5.00.5.0
path-1.8.21.8.3
petitparser-5.1.05.1.0
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
test_api-0.4.160.4.18
vector_math-2.1.42.1.4
win32-3.1.34.1.1
xml-6.2.26.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.