fly 0.0.3
fly: ^0.0.3

CLI for building beautiful flutter apps

0
likes
5 / 110
pub points
0 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 5 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.24.0 <=2.0.0"
  │        ^^^^^^^^^^^^^^^^^^
  ╵
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:args/args.dart'.

bin/fly.dart:1:8

  ╷
1 │ import 'package:args/args.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/fly.dart

ERROR: The name 'ArgParser' isn't a class.

bin/fly.dart:27:22

   ╷
27 │   final parser = new ArgParser();
   │                      ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/fly.dart

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.12.0-51.0.dev. Cannot run `pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.24.0 <=2.0.0"
  │        ^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.12.0-51.0.dev.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.24.0 <=2.0.0"
  │        ^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (2.12.0)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.24.0 <=2.0.0"
  │        ^^^^^^^^^^^^^^^^^^
  ╵