Best Flutter Framework for Beautiful Code and Programming Artisans.
The purpose of this framework is to encourage organized code, and break files up into their proper function.
This framework can work and be incorporated into any existing project! All you need to do is run the init command in the project directory.
We break up the project into 3 main directories.
- Services - contain logic that is used in multiple widgets.
- Styles - contains styles that are used in multiple widgets.
- Widgets - a directory that contains all the project's widgets
When creating a widget our CLI will automatically create the correct directory structure, break the widget into an organized set of files, and import the correct files needed to run.
It creates 3 files
- Style - contains that particular widget's styles
- View - contains the view and look of that widget
- Widget - contains that particular widget logic.
if you create a widget called login
widgets --login ----login.style.dart ----login.view.dart ----login.widget.dart
initilize existing project to work with existing commands
cd to/flutter/project fly init
creats directories and files for the fly framework
services styles --default.style.dart widgets --home ----home.style.dart ----home.view.dart ----home.widget.dart
Generate Widget #
Create an additional widget. By default this will create a stateless widget
fly generate widget login
Create a Sateless Widget #
fly generate widget:stateless login
gw: stands for "generate widget", this helps reduce time it takes to type out the full thing.
fly gw:stateless login
Create a Sateful Widget #
fly generate widget:stateful login
fly gw:stateful login
Use this package as an executable
1. Install it
You can install the package from the command line:
$ pub global activate fly
2. Use it
The package has the following executables:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.6
Analysis issues and suggestions
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.7.1. Because fly requires SDK version >=1.24.0 <=2.0.0, version solving failed.
dartfmt to format
dartfmt to format
dartfmt to format
Maintenance issues and suggestions
Support future stable Dart 2 SDKs in
pubspec.yaml. (-20 points)
The SDK constraint in
pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
Package is getting outdated. (-66.85 points)
The package was last published 87 weeks ago.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=1.24.0 <=2.0.0|