flutterfoundation 0.0.2
flutterfoundation: ^0.0.2

A new Flutter plugin.

0
likes
50 / 110
pub points
27 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 180 API elements (28.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutterfoundation/flutterfoundation.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'Application.dart'.

lib/flutterfoundation/foundation_config_until.dart:4:8

  ╷
4 │ import 'Application.dart';
  │        ^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutterfoundation/foundation_config_until.dart

ERROR: Undefined name 'Application'.

lib/flutterfoundation/foundation_config_until.dart:7:50

  ╷
7 │   static FoundationConfig goalFoundationConfig = Application.getIt<FoundationConfig>();
  │                                                  ^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutterfoundation/foundation_config_until.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.93.0.103.0.10
fluro^1.5.11.7.81.7.8
flustars^0.3.20.3.30.3.3
fluttertoast^3.1.33.1.37.1.4
get_it^3.0.33.1.05.0.1
provider^3.2.03.2.04.3.2+2
shared_preferences^0.5.60.5.12+40.5.12+4
uuid^2.2.02.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
common_utils-1.2.11.2.1
convert-2.1.12.1.1
crypto-2.1.52.1.5
decimal-0.3.50.3.5
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider-1.6.241.6.24
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
rational-0.3.80.3.8
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+30.0.1+3
source_span-1.7.01.8.0-nullsafety.4
sp_util-1.0.11.0.1
string_scanner-1.0.51.1.0-nullsafety.3
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.1.3` on fluttertoast does not support the latest published version `7.1.4`

pubspec.yaml:23:17

   ╷
23 │   fluttertoast: ^3.1.3
   │                 ^^^^^^
   ╵
The constraint `^3.0.3` on get_it does not support the latest published version `5.0.1`

pubspec.yaml:19:11

   ╷
19 │   get_it: ^3.0.3
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs