flutter_wp_woocommerce 1.0.0 copy "flutter_wp_woocommerce: ^1.0.0" to clipboard
flutter_wp_woocommerce: ^1.0.0 copied to clipboard

Woocommerce SDK for Flutter. The Complete Woo Commerce SDK for building Flutter Ecommerce Applications with amazing features.

7
likes
60/ 160
pub points
70%
popularity

We analyzed this package 2 days ago, and awarded it 60 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/MicroProgramer/flutter_woocommerce was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_wp_woocommerce,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

79 out of 1400 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: cart, cart.WooCart, cart.WooCart.WooCart, cart.WooCart.currency, cart.WooCart.WooCart.fromJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_wp_woocommerce/utilities/local_db.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that imports:
  • package:flutter_secure_storage_platform_interface/flutter_secure_storage_platform_interface.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

ERROR: Missing concrete implementations of 'getter WidgetsLocalizations.reorderItemDown', 'getter WidgetsLocalizations.reorderItemLeft', 'getter WidgetsLocalizations.reorderItemRight', 'getter WidgetsLocalizations.reorderItemToEnd', and 2 more.

lib/generated/i18n.dart:11:7

   ╷
11 │ class S implements WidgetsLocalizations {
   │       ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/generated/i18n.dart

ERROR: Missing concrete implementations of 'getter WidgetsLocalizations.reorderItemDown', 'getter WidgetsLocalizations.reorderItemLeft', 'getter WidgetsLocalizations.reorderItemRight', 'getter WidgetsLocalizations.reorderItemToEnd', and 2 more.

lib/generated/i18n.dart:25:7

   ╷
25 │ class $en extends S {
   │       ^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/generated/i18n.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.2 3.0.3 3.0.3
flutter flutter 0.0.0 0.0.0
flutter_secure_storage ^7.0.0 7.0.1 9.2.2
http ^0.13.5 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_secure_storage_linux - 1.2.1 1.2.1
flutter_secure_storage_macos - 2.0.1 3.1.2
flutter_secure_storage_platform_interface - 1.1.2 1.1.2
flutter_secure_storage_web - 1.2.1 1.2.1
flutter_secure_storage_windows - 1.1.3 3.1.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.0` on flutter_secure_storage does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • NON_ABSTRACT_CLASS_INHERITS_ABSTRACT_MEMBER - lib/generated/i18n.dart:11:7 - Missing concrete implementations of 'getter WidgetsLocalizations.reorderItemDown', 'getter WidgetsLocalizations.reorderItemLeft', 'getter WidgetsLocalizations.reorderItemRight', 'getter WidgetsLocalizations.reorderItemToEnd', and 2 more.
  • NON_ABSTRACT_CLASS_INHERITS_ABSTRACT_MEMBER - lib/generated/i18n.dart:25:7 - Missing concrete implementations of 'getter WidgetsLocalizations.reorderItemDown', 'getter WidgetsLocalizations.reorderItemLeft', 'getter WidgetsLocalizations.reorderItemRight', 'getter WidgetsLocalizations.reorderItemToEnd', and 2 more.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
60
pub points
70%
popularity

Publisher

unverified uploader

Woocommerce SDK for Flutter. The Complete Woo Commerce SDK for building Flutter Ecommerce Applications with amazing features.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

crypto, flutter, flutter_secure_storage, http

More

Packages that depend on flutter_wp_woocommerce