flutter_widget 1.0.10

flutter_widget #

开发常用 widget #

底部插入监听 BottomInsertObserver 保持页面状态 KeepAlive 监听键盘事件 KeyboardStateWidget,KeyboardStateProvider

常用工具 #

屏幕适配 ScreenUtil

[0.0.1]

  • 添加 keep_alive.dart

[0.0.2]

  • 更新了相关配置

[0.0.3]

  • 添加了 edge_insert_observer.dart

[1.0.1]

  • 更新了相关配置

[1.0.2]

  • 添加 keyboard_state_widget

[1.0.3]

  • keyboard_state_widget 优化,添加example

[1.0.4]

  • 优化,添加 KeyboardStateProvider 用于全局监听键盘状态

[1.0.5]

  • 添加屏幕适配工具 ScreenUtil

[1.0.6]

  • ScreenUtil 更新

[1.0.7]

  • 添加 .gitignore

[1.0.8]

  • bug fix

[1.0.9]

  • 键盘是否弹出改为底部插入值
  • bug fix
  • example 代码更改
  • Provider 依赖升级到 3.2.0

[1.0.10]

  • KeyboardStateProvider 添加 KeyboardState 字段,方便控制键盘相关参数

example/README.md

example #

参考源码

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_widget: ^1.0.10

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_widget/flutter_widget.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Feb 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/widget/edge_insert_observer.dart.

Run flutter format to format lib/widget/edge_insert_observer.dart.

Format lib/widget/keyboard_state_widget.dart.

Run flutter format to format lib/widget/keyboard_state_widget.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (provider).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
provider 3.2.0 3.2.0 4.0.4
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test