flutter_widget 1.0.10
flutter_widget: ^1.0.10 copied to clipboard

Develop common widget extensions to support development often encountered problems, such as PageView save state, get keyboard popup completion events

1
likes
80 / 130
pub points
16 %
popularity

We analyzed this package on May 8, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 52 API elements (51.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/widget/edge_insert_observer.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/widget/keyboard_state_widget.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
provider3.2.03.2.05.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `3.2.0` on provider does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

1
likes
80
pub points
16%
popularity

Develop common widget extensions to support development often encountered problems, such as PageView save state, get keyboard popup completion events

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

t604045540@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, provider

More

Packages that depend on flutter_widget