flutter_versio_frigidus 1.1.0 copy "flutter_versio_frigidus: ^1.1.0" to clipboard
flutter_versio_frigidus: ^1.1.0 copied to clipboard

A tool for easily selecting Flutter version on project basis

0
likes
130/ 140
pub points
31%
popularity

We analyzed this package 31 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 18 API elements (61.1 %) have documentation comments.

Some symbols that are missing documentation: cli, cli_opts, cli_opts.CliOpts.freeze, cli_opts.CliOpts.freezeRevision, cli_opts.CliOpts.restore.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_versio_frigidus/flutter_versio_frigidus.dart that imports:
  • package:flutter_versio_frigidus/core/fvf_core.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.0 2.5.0 2.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

0
likes
130
pub points
31%
popularity

Publisher

unverified uploader

A tool for easily selecting Flutter version on project basis

Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

args

More

Packages that depend on flutter_versio_frigidus