flutter_value_bloc 1.1.0
flutter_value_bloc: ^1.1.0 copied to clipboard

Flutter Widgets that make it easy to implement the ValueBloc for list, table and more.

1
likes
110/ 130
pub points
38%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 65 out of 197 API elements (33.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

lib/src/cubit_views/CubitViews.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/cubit_views/ValueViewBuilder.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^5.0.05.1.15.1.1
flutterflutter0.0.00.0.0
flutter_bloc^7.0.07.1.08.0.0
provider^5.0.05.0.06.0.1
pull_to_refresh^2.0.02.0.02.0.0
value_bloc^1.1.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
bloc-7.2.18.0.1
built_value-8.1.38.1.3
characters-1.1.01.2.0
collection-1.15.01.15.0
dartz-0.10.00.10.0
equatable-2.0.32.0.3
fixnum-1.0.01.0.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
pure_extensions-3.4.14.0.3
quiver-3.0.1+13.0.1+1
rational-1.2.11.2.1
rxdart-0.27.30.27.3
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
time-2.0.12.0.1
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.0` on flutter_bloc does not support the stable version `8.0.0`, that was published 7 days ago.

When flutter_bloc is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

The constraint `^5.0.0` on provider does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

1
likes
110
pub points
38%
popularity

Flutter Widgets that make it easy to implement the ValueBloc for list, table and more.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

built_collection, flutter, flutter_bloc, provider, pull_to_refresh, value_bloc

More

Packages that depend on flutter_value_bloc