flutter_use_sensors 0.0.4 copy "flutter_use_sensors: ^0.0.4" to clipboard
flutter_use_sensors: ^0.0.4 copied to clipboard

Collection of Flutter Hooks.

2
likes
110/ 140
pub points
6%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Unlicense.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

4 out of 21 API elements (19.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_use_sensors, flutter_use_sensors.AccelerometerState, flutter_use_sensors.AccelerometerState.AccelerometerState, flutter_use_sensors.AccelerometerState.accelerometer, flutter_use_sensors.AccelerometerState.fetched.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_use_sensors/flutter_use_sensors.dart that imports:
  • package:flutter_use_sensors/src/use_magnetometer.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_use_sensors/flutter_use_sensors.dart that imports:
  • package:flutter_use_sensors/src/use_magnetometer.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_use_sensors/flutter_use_sensors.dart that imports:
  • package:flutter_use_sensors/src/use_magnetometer.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_hooks ^0.20.0 0.20.5 0.20.5
sensors_plus ^1.2.1 1.4.1 4.0.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sensors_plus_platform_interface - 1.2.0 1.2.0
sensors_plus_web - 1.1.2 1.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.1` on sensors_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sensors_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.