flutter_ui 0.0.9
flutter_ui: ^0.0.9 copied to clipboard

A Flutter UI package,include action sheet,badge,button,check list,datetime picker, field,index list etc...

11
likes
90 / 130
pub points
66 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 101 out of 219 API elements (46.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_ui/cupertino.dart that imports:
  • package:flutter_ui/src/cupertino/cupertino_browser.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^1.1.2+11.1.33.0.0
flutterflutter0.0.00.0.0
fluttertoast^3.1.33.1.38.0.7
webview_flutter^0.3.15+10.3.242.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_cache_manager-1.4.23.1.2
http-0.12.20.13.3
http_parser-3.1.44.0.0
meta-1.3.01.4.0
path-1.8.01.8.0
path_provider-1.6.282.0.2
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.11.11.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
rxdart-0.24.10.27.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+3
sqflite_common-1.0.3+32.0.0+2
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
win32-2.2.42.2.4
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.1.2+1` on cached_network_image does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^3.1.3` on fluttertoast does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions fluttertoast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

11
likes
90
pub points
66%
popularity

Publisher

flutter-jp.com

A Flutter UI package,include action sheet,badge,button,check list,datetime picker, field,index list etc...

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cached_network_image, flutter, fluttertoast, webview_flutter

More

Packages that depend on flutter_ui