flutter_stringprocess 0.1.0 icon indicating copy to clipboard operation
flutter_stringprocess: ^0.1.0 copied to clipboard

String processing library

0
likes
60/ 120
pub points
11%
popularity

We analyzed this package 7 hours ago, and awarded it 60 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 10icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_stringprocess.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.17.0.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on stream_channel >=2.1.0-nullsafety <2.[...]
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7, test >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires stream_channel >=2.1.0-nullsafety <2[...]
And because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19, test >=1.15.5 <1.16.6 requires stream_channel >=2.1.0[...]
And because test >=1.16.6 <1.16.7 depends on test_core 0.3.17 and test >=1.16.7 <1.17.0 depends on test_api 0.3.0, test >=1.15.5 <1.17.0 requires stream_channel >=2.1.0-nullsafety <2.1.0 or test_[...]
And because test >=1.17.0 <1.17.6 depends on test_api 0.4.0 and test >=1.17.6 <1.17.10 depends on test_api 0.4.1, test >=1.15.5 <1.17.10 requires stream_channel >=2.1.0-nullsafety <2.1.0 or test_[...]
And because test >=1.17.10 <1.17.11 depends on test_core 0.4.0 and test >=1.17.11 <1.18.0 depends on test_api 0.4.3, test >=1.15.5 <1.18.0 requires stream_channel >=2.1.0-nullsafety <2.1.0 or tes[...]
And because test >=1.18.0 <1.18.1 depends on test_core 0.4.3 and test >=1.18.1 <1.19.0 depends on test_api 0.4.5, test >=1.15.5 <1.19.0 requires stream_channel >=2.1.0-nullsafety <2.1.0 or test_a[...]
And because test >=1.19.0 <1.19.3 depends on test_api 0.4.6 and test >=1.19.3 <1.19.4 depends on test_core 0.4.8, test >=1.15.5 <1.19.4 requires stream_channel >=2.1.0-nullsafety <2.1.0 or test_a[...]
[6 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.