flutter_stringprocess 0.1.2
flutter_stringprocess: ^0.1.2 copied to clipboard

The flutter_stringprocess package defines a set of methods to process strings.

0
likes
100/ 130
pub points
1%
popularity

We analyzed this package on Oct 13, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 36 out of 38 API elements (94.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.14.3.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0,[...]
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7, test >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0[...]
And because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19, test >=1.15.5 <1.16.6 requires typed_data >=1.3.0-nul[...]
And because test >=1.16.6 <1.16.7 depends on test_core 0.3.17 and test >=1.16.7 <1.17.0 depends on test_api 0.3.0, test >=1.15.5 <1.17.0 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api [...]
And because test >=1.17.0 <1.17.6 depends on test_api 0.4.0 and test >=1.17.6 <1.17.10 depends on test_api 0.4.1, test >=1.15.5 <1.17.10 requires test_api 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.1[...]
And because test >=1.18.1 depends on test_api 0.4.5 and test >=1.17.11 <1.18.0 depends on test_api 0.4.3, test >=1.15.5 <1.17.10-∞ or >=1.17.11 <1.18.0-∞ or >=1.18.1 requires test_api 0.2.18+1 or[...]
And because test >=1.18.0 <1.18.1 depends on test_core 0.4.3 and test >=1.17.10 <1.17.11 depends on test_core 0.4.0, test >=1.15.5 requires test_api 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or 0[...]
And because every version of flutter_test from sdk depends on both typed_data 1.3.0 and test_api 0.4.2, if flutter_test any from sdk and test >=1.15.5 then test_core 0.3.17 or 0.4.0 or 0.4.3.
[3 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
100
pub points
1%
popularity

Publisher

killy.io

The flutter_stringprocess package defines a set of methods to process strings.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, html_unescape, markdown

More

Packages that depend on flutter_stringprocess