flutter_snow_blower 0.2.1
flutter_snow_blower: ^0.2.1

Dart native
Flutter Android iOS

A CLI package that helps you to start a project, maintain and generate new pages, controllers, modules with flutter_modular. Using the Clean architecture or MVC architecture

9
likes
90 / 110
pub points
16 %
popularity

We analyzed this package on Nov 29, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 48 out of 122 API elements (39.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_snow_blower/flutter_snow_blower.dart that imports:
  • package:flutter_snow_blower/src/modules/modules.dart that imports:
  • package:flutter_snow_blower/src/modules/upgrade.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Dead code.

lib/src/utils/pubspec.dart:43:7

   ╷
43 │       return null;
   │       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/utils/pubspec.dart

lib/src/command/sub_command/generate_module_sub_command.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.51.1.11.1.1
args^1.6.01.6.01.6.0
dart_console^0.6.20.6.20.6.2
http^0.12.20.12.20.12.2
path^1.7.01.7.01.7.0
pubspec_yaml^2.0.12.0.12.0.1
recase^3.0.03.0.13.0.1
tuple^1.0.31.0.31.0.3
yaml^2.2.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
ffi-0.1.30.1.3
functional_data-0.3.00.3.0
http_parser-3.1.43.1.4
json2yaml-1.0.11.0.1
matcher-0.12.90.12.9
meta-1.2.41.2.4
plain_optional-0.1.30.1.3
quiver-2.1.52.1.5
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
sum_types-0.2.1+20.2.1+2
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
win32-1.7.41.7.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
90
pub points
16%
popularity

Publisher

snowmanlabs.com

A CLI package that helps you to start a project, maintain and generate new pages, controllers, modules with flutter_modular. Using the Clean architecture or MVC architecture

Homepage
Repository (GitLab)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

ansicolor, args, dart_console, http, path, pubspec_yaml, recase, tuple, yaml

More

Packages that depend on flutter_snow_blower