flutter_shake_plugin 0.0.2
flutter_shake_plugin: ^0.0.2 copied to clipboard

A new Flutter plugin for detecting phone shake and support vibration.

5
likes
90 / 130
pub points
71 %
popularity

We analyzed this package on May 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 13 API elements (84.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_shake_plugin/flutter_shake_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
sensors^0.4.0+10.4.2+62.0.0
vibration^1.0.21.7.31.7.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
vibration_web-1.6.21.6.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0+1` on sensors does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sensors to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

5
likes
90
pub points
71%
popularity

A new Flutter plugin for detecting phone shake and support vibration.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

846451206@qq.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, sensors, vibration

More

Packages that depend on flutter_shake_plugin