flutter_searchbox 1.2.0
flutter_searchbox: ^1.2.0 copied to clipboard

Flutter Searchbox provides declarative API to query Elasticsearch, and binds UI widgets with different types of search queries. As the name suggests, it provides a searchbox UI widget for Elasticsearc

8
likes
80/ 130
pub points
61%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 141 out of 154 API elements (91.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_searchbox/flutter_searchbox.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_feather_icons^1.0.31.0.32.0.0+1
provider^4.3.2+34.3.36.0.0
searchbase^1.0.11.0.12.2.0
speech_to_text^3.1.03.2.05.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
js-0.6.30.6.3
json_annotation-3.1.14.1.0
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
speech_to_text_platform_interface-1.4.22.0.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.0.3` on flutter_feather_icons does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_feather_icons to update the constraint.

The constraint `^4.3.2+3` on provider does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

8
likes
80
pub points
61%
popularity

Publisher

appbase.io

Flutter Searchbox provides declarative API to query Elasticsearch, and binds UI widgets with different types of search queries. As the name suggests, it provides a searchbox UI widget for Elasticsearch and Appbase.io.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_feather_icons, provider, searchbase, speech_to_text

More

Packages that depend on flutter_searchbox