flutter_scandit 0.0.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 71

Flutter Scandit #

pub package

Flutter Plugin for Scandit Barcode Scanning

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Features: #

  • Scan a barcode on demand

Platforms: #

  • Android
  • iOS

Installation #

First, add flutter_scandit as a dependency in your pubspec.yaml file.

iOS #

Add the following to the ios/Runner/Info.plist:

  • The key Privacy - Camera Usage Description and a usage description.

Or in text format add the key:

<key>NSCameraUsageDescription</key>
<string>Can I use the camera for scanning?</string>

Min target is iOS 9.0

Android #

Min SDK version should be 19 or later

minSdkVersion 19

Example #

An exmaple with specific symbologies

BarcodeResult result = await FlutterScandit(symbologies: [
  Symbology.EAN13_UPCA,
  Symbology.CODE128,
  // - any other valid sumbologies
], licenseKey: "-- ENTER YOUR SCANDIT LICENSE KEY HERE -") // use your scandit key here
    .scanBarcode();
String barcodeData = result.data; // actual barcode string

You should always pass the intended symbologies along with your call. It is also important to check that the symbologies you are selecting align with your Scandit license restrictions.

Since the actual keys will be different per platoform, it is advised to abtract this out using environment variables or global configuration that can be changed per build/environment.

0.0.1 #

  • scanBarcode method that opens a camera views and exits once an item has been scanned or the user disimisses the scanner.

0.0.2 #

  • handle bug for android initialisation in release mode (passing of symbologies and licensekey)

0.0.3 #

  • Fix bug with Android intent filters (should not auto-launch scanner)

0.0.4 #

  • Handle potential bug with iOS navigation (pop navigationController on dismiss)

0.0.5 #

  • Handle iOS issues on scanner dismiss

0.0.6 #

  • Dismiss on correct thread

example/README.md

flutter_scandit_example #

Demonstrates how to use the flutter_scandit plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_scandit: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_scandit/flutter_scandit.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

41 out of 41 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test