flutter_rave 0.0.5
flutter_rave: ^0.0.5

Flutter Android iOS

Flutterwave's Rave Card Processing Plugin. Completely supports Android and iOS.

11
likes
70 / 110
pub points
78 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 54 API elements (7.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_rave/flutter_rave.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 26 issues. Showing the first 2:

INFO: The value of the field 'route' isn't used.

lib/flutter_rave.dart:126:17

    ╷
126 │   static String route = "/debit-cards/add";
    │                 ^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_rave.dart

INFO: 'subtitle' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle2. This feature was deprecated after v1.13.8..

lib/flutter_rave.dart:463:60

    ╷
463 │                         style: Theme.of(context).textTheme.subtitle.copyWith(
    │                                                            ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_rave.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.0.62.1.52.1.5
cupertino_icons^0.1.20.1.31.0.1+1
dio^2.1.02.2.23.0.10
dio_flutter_transformer^2.0.102.0.103.0.2
equatable^0.2.30.2.61.2.5
flushbar^1.3.01.10.41.10.4
flutter_svg^0.13.10.13.10.19.2+1
flutter_webview_plugin^0.3.50.3.110.3.11
intl^0.15.80.15.80.16.1
tripledes^2.1.02.1.02.1.0
url_launcher^5.0.25.7.105.7.10
webview_flutter^0.3.90.3.241.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
cookie_jar-1.0.11.0.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
petitparser-3.1.03.1.0
plugin_platform_interface-1.0.31.0.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
url_launcher_linux-0.0.1+40.0.1+4
url_launcher_macos-0.0.1+90.0.1+9
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.5+10.1.5+1
url_launcher_windows-0.0.1+30.0.1+3
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
xml-3.7.04.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.1+1`

pubspec.yaml:11:20

   ╷
11 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵
The constraint `^2.1.0` on dio does not support the latest published version `3.0.10`

pubspec.yaml:13:8

   ╷
13 │   dio: ^2.1.0
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs