flutter_qr_bar_scanner 1.0.2
flutter_qr_bar_scanner: ^1.0.2

Flutter Android iOS

A Plugin for reading/scanning QR & Bar codes using Google's Mobile Vision API.

20
likes
70 / 110
pub points
90 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 82 API elements (11.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_qr_bar_scanner/flutter_qr_bar_scanner.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_qr_bar_scanner.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/qr_bar_scanner_camera.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
native_device_orientation^0.3.00.3.00.4.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on native_device_orientation does not support the latest published version `0.4.3`

pubspec.yaml:22:30

   ╷
22 │   native_device_orientation: ^0.3.0
   │                              ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

20
likes
70
pub points
90%
popularity

A Plugin for reading/scanning QR & Bar codes using Google's Mobile Vision API.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

contact.lutforrahman@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, native_device_orientation

More

Packages that depend on flutter_qr_bar_scanner