flutter_paw_ffi 2.0.4 copy "flutter_paw_ffi: ^2.0.4" to clipboard
flutter_paw_ffi: ^2.0.4 copied to clipboard

Low-level library for the PAW digital currency. Supports signatures, key generation, and more. Uses C functions for ed25519 and blake2b.

0
likes
120/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/paw-digital/flutter_paw_ffi was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_paw_ffi,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

29 out of 111 API elements (26.1 %) have documentation comments.

Some symbols that are missing documentation: flutter_paw_ffi, flutter_paw_ffi.BlockHash, flutter_paw_ffi.Checksum, flutter_paw_ffi.Ed25519Blake2b, flutter_paw_ffi.Ed25519Blake2b.Ed25519Blake2b.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_paw_ffi/flutter_paw_ffi.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_paw_ffi/flutter_paw_ffi.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_paw_ffi/flutter_paw_ffi.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_paw_ffi/flutter_paw_ffi.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'true'.

lib/src/account/account_util.dart:27:20

   ╷
27 │     assert(account != null);
   │                    ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/account/account_util.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/src/account/account_util.dart:37:20

   ╷
37 │     assert(account != null);
   │                    ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/account/account_util.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bip39 ^1.0.6 1.0.6 1.0.6
ffi ^1.0.0 1.2.1 2.1.2
flutter flutter 0.0.0 0.0.0
hex ^0.2.0 0.2.0 0.2.0
pointycastle ^3.0.1 3.9.1 3.9.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Low-level library for the PAW digital currency. Supports signatures, key generation, and more. Uses C functions for ed25519 and blake2b.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

bip39, ffi, flutter, hex, pointycastle

More

Packages that depend on flutter_paw_ffi