flutter_paw_ffi 2.0.4 icon indicating copy to clipboard operation
flutter_paw_ffi: ^2.0.4 copied to clipboard

Low-level library for the PAW digital currency. Supports signatures, key generation, and more. Uses C functions for ed25519 and blake2b.

Flutter PAW FFI #

A PAW, Nano, Banano cryptocurrency library for the Dart programming language

Based on NanoDart, but uses C functions for blake2b hashing and ed25519 cryptogaphy - using Dart's FFI features.

Features #

NanoDart supports seed generation, key derivation, validators, signing, block creation, and other essential functions of the Nano and Banano cryptocurrencies.

Usage #

See the example and test folders for examples and usage.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0
likes
110
pub points
0%
popularity

Publisher

unverified uploader

Low-level library for the PAW digital currency. Supports signatures, key generation, and more. Uses C functions for ed25519 and blake2b.

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

bip39, ffi, flutter, hex, pointycastle

More

Packages that depend on flutter_paw_ffi