flutter_parse 1.0.1 icon indicating copy to clipboard operation
flutter_parse: ^1.0.1 copied to clipboard

Plugin for managing and accessing Parse Server for Dart VM and Flutter.

15
likes
130/ 140
pub points
74%
popularity

We analyzed this package 3 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 263 out of 337 API elements (78.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 32 issues. Showing the first 2:

INFO: The import of 'parse_file.dart' is unnecessary because all of the used elements are also provided by the import of '../flutter_parse.dart'.

lib/src/parse_config.dart:8:8

  ╷
8 │ import 'parse_file.dart';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/parse_config.dart

INFO: The import of 'parse_geo_point.dart' is unnecessary because all of the used elements are also provided by the import of '../flutter_parse.dart'.

lib/src/parse_config.dart:9:8

  ╷
9 │ import 'parse_geo_point.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/parse_config.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutter_parse_storage_interface^1.0.21.0.21.0.2
http^0.13.30.13.50.13.5
meta^1.7.01.8.01.8.0
web_socket_channel^2.1.02.2.02.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
collection-1.17.01.17.0
crypto-3.0.23.0.2
http_parser-4.0.24.0.2
path-1.8.21.8.2
source_span-1.9.11.9.1
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.20, Dart 2.18.4.

15
likes
130
pub points
74%
popularity

Publisher

verified publisher iconmesosfer.com

Plugin for managing and accessing Parse Server for Dart VM and Flutter.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter_parse_storage_interface, http, meta, web_socket_channel

More

Packages that depend on flutter_parse