flutter_minizip_ffi_bindings 0.3.0 copy "flutter_minizip_ffi_bindings: ^0.3.0" to clipboard
flutter_minizip_ffi_bindings: ^0.3.0 copied to clipboard

FFI bindings for [zlib-ng/minizip-ng](https://github.com/zlib-ng/minizip-ng) made using [dart-lang/ffigen](https://github.com/dart-lang/ffigen) and trivial trick.

3
likes
110/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

38 out of 491 API elements (7.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_minizip_ffi_bindings, flutter_minizip_ffi_bindings.DIR, flutter_minizip_ffi_bindings.DIR.DIR, flutter_minizip_ffi_bindings.MZ_AES_BLOCK_SIZE, flutter_minizip_ffi_bindings.MZ_AES_ENCRYPTION_MODE_128.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_minizip_ffi_bindings/flutter_minizip_ffi_bindings.dart that imports:
  • dart:ffi
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_minizip_ffi_bindings.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.1.2 1.2.1 2.1.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.2` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

3
likes
110
pub points
0%
popularity

Publisher

unverified uploader

FFI bindings for [zlib-ng/minizip-ng](https://github.com/zlib-ng/minizip-ng) made using [dart-lang/ffigen](https://github.com/dart-lang/ffigen) and trivial trick.

Repository (GitLab)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ffi, flutter

More

Packages that depend on flutter_minizip_ffi_bindings