flutter_midi 1.0.1

1.0.1 #

  • Bumping Version
  • Adding Web Example
  • Adding Online Demo

1.0.0 - 05.04.2019 #

  • Support for Desktop (Path Only)

0.2.0 - 04.06.2019 #

  • Updating Example to be desktop aware

0.1.1 #

  • Added Ability to Change .sf2 File Being Played
  • Updated Example

0.1.0 #

  • Removed Need to Bundle .sf2 on iOS
  • Added .sf2 Support for Android
  • Added Ability to Cancel any note for true polyphony
  • Updated Example
  • Changed way SoundFont is Loaded (From Asset Folder)

0.0.4 #

  • Fixing Android Bug
  • Added Midi to Android

0.0.2 #

  • Optional force unmute

0.0.1 #

  • Added Midi for iOS.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_midi: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_midi/flutter_midi.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
80
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
29
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance issues and suggestions

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: flutter_midi_platform_interface.

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_midi.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_midi_platform_interface any 0.0.1
flutter_web_plugins 0.0.0
meta ^1.0.5 1.1.8
path_provider ^1.6.0 1.6.5
path_provider_macos ^0.0.3 0.0.4
plugin_platform_interface ^1.0.1 1.0.2
tonic ^0.2.3 0.2.3
Transitive dependencies
collection 1.14.11 1.14.12
path_provider_platform_interface 1.0.1
platform 2.2.1
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.1.1
test ^1.3.0