path_provider_macos 0.0.3

path_provider_macos #

The macos implementation of [path_provider].

Usage #

Import the package #

To use this plugin in your Flutter macos app, simply add it as a dependency in your pubspec.yaml alongside the base path_provider plugin.

(This is only temporary: in the future we hope to make this package an "endorsed" implementation of path_provider, so that it is automatically included in your Flutter macos app when you depend on package:path_provider.)

This is what the above means to your pubspec.yaml:

  path_provider: ^1.5.1
  path_provider_macos: ^0.0.1

Use the plugin #

Once you have the path_provider_macos dependency in your pubspec, you should be able to use package:path_provider as normal.

0.0.3 #

  • Added support for user's downloads directory.

0.0.2+1 #

  • Update README.

0.0.1 #

  • Initial open source release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  path_provider_macos: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8