flutter_map_firestore 0.0.4
flutter_map_firestore: ^0.0.4

Flutter Android iOS

Firestore for Flutter Map

2
likes
50 / 110
pub points
18 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 8 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_map_firestore/flutter_map_firestore.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_map_firestore.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^0.8.2+10.8.2+30.14.3+1
flutter_map^0.1.40.1.40.10.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.11.1.1
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
console_log_handler-1.1.61.1.6
firebase_core-0.2.5+10.5.2+1
intl-0.16.10.16.1
latlong-0.6.10.6.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.7.0
quiver-2.1.52.1.5
stack_trace-1.9.61.9.6
transparent_image-0.1.01.0.0
tuple-1.0.31.0.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
validate-1.7.01.7.0
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.2+1` on cloud_firestore does not support the latest published version `0.14.3+1`

pubspec.yaml:13:20

   ╷
13 │   cloud_firestore: ^0.8.2+1
   │                    ^^^^^^^^
   ╵
The constraint `^0.1.4` on flutter_map does not support the latest published version `0.10.1+1`

pubspec.yaml:14:16

   ╷
14 │   flutter_map: ^0.1.4
   │                ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs