flutter_map_firestore 0.0.4

  • Readme
  • Changelog
  • Installing
  • 49

flutter_map_firestore #

Firestore for Flutter Map Plugin: flutter_map

Add flutter_map_firestore to your pubspec:

dependencies:
  flutter_map_firestore: ^0.0.4

Usage:

import 'package:cloud_firestore/cloud_firestore.dart';
import 'package:flutter/material.dart';
import 'package:flutter/widgets.dart';
import 'package:flutter_map/flutter_map.dart';
import 'package:latlong/latlong.dart';
import 'package:flutter_map_firestore/flutter_map_firestore.dart';

class Map extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new FlutterMap(
      options: new MapOptions(
        plugins: [FirestoreMarkerPlugin()],
      ),
      layers: [
        new TileLayerOptions(
            urlTemplate: "https://{s}.tile.openstreetmap.org/{z}/{x}/{y}.png",
            subdomains: ['a', 'b', 'c']),
        new FirestoreMarkerLayerOptions(Firestore.instance.collection('markers'), //connect own firestore collection
            (document) {
          GeoPoint point = document["location"]; //use for example Firestore GeoPoint
          return Marker(
              width: 50.0,
              height: 50.0,
              point: LatLng(point.latitude, point.longitude),
              builder: (ctx) => new Container(
                    child: new FlutterLogo(),
                  ));
        }),
      ],
    );
  }
}

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.3] - Dart2 compatibiliy.

  • Rename Firebase to Firestore

[0.0.2] - Class renaming Release.

  • Rename Firebase to Firestore

[0.0.1] - Core Release.

  • Ability to manage markers by Firestore Database via Stream

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_map_firestore: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_map_firestore/flutter_map_firestore.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
23
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_map_firestore.dart.

Run flutter format to format lib/flutter_map_firestore.dart.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (cloud_firestore, flutter_map).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_map_firestore.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
cloud_firestore ^0.8.2+1 0.8.2+3 0.12.9+5
flutter 0.0.0
flutter_map ^0.1.4 0.1.4 0.7.3
Transitive dependencies
ansicolor 1.0.2
collection 1.14.11 1.14.12
console_log_handler 1.1.6
firebase_core 0.2.5+1 0.4.0+9
intl 0.16.0
latlong 0.6.1
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
path 1.6.4
quiver 2.0.5
sky_engine 0.0.99
stack_trace 1.9.3
transparent_image 0.1.0 1.0.0
tuple 1.0.3
typed_data 1.1.6
validate 1.7.0
vector_math 2.0.8