flutter_long_list 0.1.0

Flutter Android iOS web

A Flutter LongList with Provider which supports ListView, GridView and Slivers.

2
likes
90 / 110
pub points
60 %
popularity

We analyzed this package on Oct 30, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 81 API elements (6.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: Avoid using braces in interpolation when not needed.

lib/src/store/long_list_provider.dart:79:21

   ╷
79 │       print('list id${id}没有初始化');
   │                     ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/store/long_list_provider.dart

INFO: Avoid using braces in interpolation when not needed.

lib/src/store/long_list_provider.dart:89:21

   ╷
89 │       print('list id${id}没有初始化');
   │                     ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/store/long_list_provider.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
extended_list^2.0.12.0.22.0.2
flutterflutter0.0.00.0.0
provider^4.3.24.3.2+24.3.2+2
tuple^1.0.31.0.31.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
extended_list_library-2.0.02.0.0
matcher-0.12.90.12.10-nullsafety.2
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
nested-0.0.40.0.4
path-1.7.01.8.0-nullsafety.2
quiver-2.1.4+12.1.4+1
sky_engine-0.0.990.0.99
stack_trace-1.9.51.10.0-nullsafety.5
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
90
pub points
60%
popularity

A Flutter LongList with Provider which supports ListView, GridView and Slivers.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

1258658726@qq.com

License

MIT (LICENSE)

Dependencies

extended_list, flutter, provider, tuple

More

Packages that depend on flutter_long_list