flutter_login_md 1.0.14
flutter_login_md: ^1.0.14 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A login widget with login/signup functionalities to help speed up development

1
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 53 out of 106 API elements (50.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

INFO: Unused import: 'package:flutter/scheduler.dart'.

lib/flutter_login.dart:5:8

  ╷
5 │ import 'package:flutter/scheduler.dart' show timeDilation;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_login.dart

INFO: Unused import: 'src/widgets/gradient_box.dart'.

lib/flutter_login.dart:21:8

   ╷
21 │ import 'src/widgets/gradient_box.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_login.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flushbar^1.9.11.10.41.10.4
flutterflutter0.0.00.0.0
font_awesome_flutter^8.5.08.11.08.11.0
provider^4.0.24.3.34.3.3
quiver^2.0.52.1.53.0.0
transformer_page_view^0.1.60.1.60.1.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
matcher-0.12.90.12.10
meta-1.3.0-nullsafety.31.3.0
nested-0.0.41.0.0
path-1.7.01.8.0
sky_engine-0.0.990.0.99
stack_trace-1.9.61.10.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.5` on quiver does not support the latest published version `3.0.0`

pubspec.yaml:18:11

   ╷
18 │   quiver: ^2.0.5
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

1
likes
90
pub points
0%
popularity

A login widget with login/signup functionalities to help speed up development

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ftorreillespro@gmail.com

License

MIT (LICENSE)

Dependencies

flushbar, flutter, font_awesome_flutter, provider, quiver, transformer_page_view

More

Packages that depend on flutter_login_md