flutter_ledger_lib 1.0.0 copy "flutter_ledger_lib: ^1.0.0" to clipboard
flutter_ledger_lib: ^1.0.0 copied to clipboard

A Flutter project for interacting with Ledger Nano devices.

0
likes
70/ 160
pub points
0%
popularity

We analyzed this package 1 hour ago, and awarded it 70 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 20 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: flutter_ledger_lib, flutter_ledger_lib.FlutterLedgerLib, flutter_ledger_lib.FlutterLedgerLib.bindings, flutter_ledger_lib.FlutterLedgerLib.instance, flutter_ledger_lib.LedgerDevice.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_ledger_lib/flutter_ledger_lib.dart that declares support for platforms: Windows, macOS.
Package does not support platform `iOS`.

Because:

  • package:flutter_ledger_lib/flutter_ledger_lib.dart that declares support for platforms: Windows, macOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_ledger_lib/flutter_ledger_lib.dart that declares support for platforms: Windows, macOS.
Package does not support platform `Web`.

Because:

  • package:flutter_ledger_lib/flutter_ledger_lib.dart that declares support for platforms: Windows, macOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 37 issues. Showing the first 2:

ERROR: Target of URI hasn't been generated: 'bindings.g.dart'.

lib/src/bindings.dart:4:8

  ╷
4 │ import 'bindings.g.dart';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bindings.dart

ERROR: Undefined class 'Bindings'.

lib/src/bindings.dart:9:9

  ╷
9 │   final Bindings? _bindings;
  │         ^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bindings.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.0.2 3.1.1 3.1.1
eosdart ^0.4.8 0.4.10 0.4.10
ffi ^2.0.0 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
freezed_annotation ^2.0.3 2.4.1 2.4.1
json_annotation ^4.5.0 4.9.0 4.9.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
synchronized ^3.0.0+2 3.1.0+1 3.1.0+1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
bs58check - 1.0.2 1.0.2
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
eosdart_ecc - 0.4.4 0.4.4
hex - 0.2.0 0.2.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 32 errors:

  • URI_HAS_NOT_BEEN_GENERATED - lib/src/bindings.dart:4:8 - Target of URI hasn't been generated: 'bindings.g.dart'.
  • UNDEFINED_CLASS - lib/src/bindings.dart:9:9 - Undefined class 'Bindings'.
  • UNDEFINED_METHOD - lib/src/bindings.dart:12:21 - The method 'Bindings' isn't defined for the type 'FlutterLedgerLib'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.