flutter_launchpad 1.0.2+5 copy "flutter_launchpad: ^1.0.2+5" to clipboard
flutter_launchpad: ^1.0.2+5 copied to clipboard

Flutter Library to control Novation Launchpad MIDI devices

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_launchpad

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  flutter_launchpad: ^1.0.2+5

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_launchpad/colors.dart';
import 'package:flutter_launchpad/launchpad_controller.dart';
import 'package:flutter_launchpad/launchpad_event.dart';
import 'package:flutter_launchpad/launchpad_layout.dart';
import 'package:flutter_launchpad/launchpad_models.dart';
import 'package:flutter_launchpad/launchpad_reader.dart';
import 'package:flutter_launchpad/launchpad_service.dart';
import 'package:flutter_launchpad/viewer.dart';
import 'package:flutter_launchpad/viewer/launchpad_mini_3.dart';
import 'package:flutter_launchpad/viewer/launchpad_viewer.dart';
import 'package:flutter_launchpad/viewer/novation_logo.dart';
0
likes
130
pub points
0%
popularity

Publisher

verified publisherthkp.co

Flutter Library to control Novation Launchpad MIDI devices

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_midi_command, google_fonts, rxdart

More

Packages that depend on flutter_launchpad