flutter_launcher_icons 0.9.0
flutter_launcher_icons: ^0.9.0 copied to clipboard

A package which simplifies the task of updating your Flutter app's launcher icon.

2185
likes
80 / 130
pub points
99 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 110 API elements (18.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_launcher_icons/android.dart that imports:
  • package:flutter_launcher_icons/custom_exceptions.dart that imports:
  • package:flutter_launcher_icons/utils.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/constants.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/ios.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args2.0.02.0.02.1.1
image^3.0.0-nullsafety.03.0.23.0.2
path^1.8.0-nullsafety.31.8.01.8.0
yaml^3.0.0-nullsafety.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
meta-1.4.01.4.0
petitparser-4.2.04.2.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
xml-5.1.25.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `2.0.0` on args does not support the stable version `2.1.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.17.1, Dart 2.13.1.

2185
likes
80
pub points
99%
popularity

Publisher

fluttercommunity.dev

A package which simplifies the task of updating your Flutter app's launcher icon.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, image, path, yaml

More

Packages that depend on flutter_launcher_icons