flutter_html_textview 0.2.6
flutter_html_textview: ^0.2.6 copied to clipboard

Flutter Plugin to render html in textview

3
likes
60/ 130
pub points
68%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 17 API elements (11.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_html_textview/flutter_html_textview.dart that imports:
  • package:flutter_html_textview/html_parser.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_object.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/flutter_html_text.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/flutter_html_textview.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^0.4.00.4.23.1.0
flutterflutter0.0.00.0.0
html^0.13.30.13.4+20.15.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.15.00.17.0
flutter_cache_manager-0.1.23.1.2
http-0.11.3+170.13.3
http_parser-3.1.44.0.0
meta-1.3.01.7.0
path-1.8.01.8.0
path_provider-0.4.12.0.4
shared_preferences-0.4.32.0.7
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-1.5.3+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
utf-0.9.0+50.9.0+5
uuid-1.0.33.0.4
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on cached_network_image does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.13.3` on html does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.28.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.