flutter_html 1.0.2

Flutter Android iOS

A Flutter widget rendering static HTML and CSS as Flutter widgets.

296
likes
80 / 110
pub points
99 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 71 out of 150 API elements (47.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Don't import implementation files from another package.

lib/src/styled_element.dart:5:8

  ╷
5 │ import 'package:html/src/query_selector.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/styled_element.dart

lib/html_parser.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
chewie^0.9.100.9.100.9.10
chewie_audio^1.0.0+11.0.0+11.0.0+1
css_colors^1.0.21.0.21.0.2
csslib^0.16.20.16.20.16.2
flutterflutter0.0.00.0.0
flutter_svg^0.18.00.18.10.19.0
html^0.14.0+30.14.0+30.14.0+3
video_player^0.10.11+20.10.12+50.11.0
webview_flutter^0.3.22+10.3.240.3.24
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
flutter_web_plugins-0.0.00.0.0
meta-1.1.81.2.3
open_iconic_flutter-0.3.00.3.0
path-1.7.01.7.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
petitparser-3.0.43.1.0
screen-0.0.50.0.5
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4
wakelock-0.1.4+20.1.4+2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.0` on flutter_svg does not support the latest published version `0.19.0`

pubspec.yaml:29:16

   ╷
29 │   flutter_svg: ^0.18.0
   │                ^^^^^^^
   ╵
The constraint `^0.10.11+2` on video_player does not support the latest published version `0.11.0`

pubspec.yaml:19:17

   ╷
19 │   video_player: ^0.10.11+2
   │                 ^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs