flutter_hooks_bloc 0.11.0
flutter_hooks_bloc: ^0.11.0 copied to clipboard

Flutter Android iOS web

A flutter_bloc reimplementation based on flutter_hooks with the same API.

9
likes
90 / 110
pub points
59 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 58 API elements (51.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'bloc' is deprecated and shouldn't be used. Use context.read or context.watch instead. Will be removed in v7.0.0.

lib/src/bloc_hook.dart:84:35

   ╷
84 │   final _cubit = cubit ?? context.bloc<C>();
   │                                   ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc_hook.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^6.0.36.1.16.1.1
flutter_bloc^6.0.56.1.16.1.1
flutter_hooks^0.14.00.14.10.15.0
hooks_riverpod^0.9.10.9.20.12.2
riverbloc^0.1.00.1.00.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
flutter_riverpod-0.9.10.12.2
freezed_annotation-0.11.0+10.12.0
json_annotation-3.1.13.1.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
nested-0.0.40.0.4
provider-4.3.34.3.3
riverpod-0.8.00.12.2
state_notifier-0.6.00.6.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0` on flutter_hooks does not support the latest published version `0.15.0`

pubspec.yaml:15:18

   ╷
15 │   flutter_hooks: ^0.14.0
   │                  ^^^^^^^
   ╵
The constraint `^0.9.1` on hooks_riverpod does not support the latest published version `0.12.2`

pubspec.yaml:16:19

   ╷
16 │   hooks_riverpod: ^0.9.1
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
90
pub points
59%
popularity

A flutter_bloc reimplementation based on flutter_hooks with the same API.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

frankmoreno1993@gmail.com

License

MIT (LICENSE)

Dependencies

bloc, flutter, flutter_bloc, flutter_hooks, hooks_riverpod, riverbloc

More

Packages that depend on flutter_hooks_bloc