flutter_google_street_view 3.1.4 copy "flutter_google_street_view: ^3.1.4" to clipboard
flutter_google_street_view: ^3.1.4 copied to clipboard

A flutter plugin of google street view in Web, iOS and Android applications.

37
likes
130/ 140
pub points
90%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

315 out of 371 API elements (84.9 %) have documentation comments.

Some symbols that are missing documentation: flutter_google_street_view, flutter_google_street_view.CloseClickEvent, flutter_google_street_view.ControlPosition, flutter_google_street_view.ControlPosition.toJson, flutter_google_street_view.FlutterGoogleStreetView.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_google_street_view/flutter_google_street_view.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_google_street_view/flutter_google_street_view.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_google_street_view/flutter_google_street_view.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:flutter_google_street_view/flutter_google_street_view.dart that imports:
  • package:flutter_google_street_view/src/street_view.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 73 issues. Showing the first 2:

INFO: Use the generic function type syntax in 'typedef's.

lib/src/controller.dart:12:14

   ╷
12 │ typedef void StreetViewCreatedCallback(StreetViewController controller);
   │              ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/controller.dart:49:7

   ╷
49 │       _isPanningGesturesEnabled = initSetting['isPanningGesturesEnabled']!;
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.1 2.0.17 2.0.17
flutter_web_plugins flutter 0.0.0 0.0.0
google_maps ^6.1.0 6.3.0 7.1.0
kotlin_scope_function ^1.0.0 1.0.2 1.0.2
meta ^1.3.0 1.11.0 1.12.0
street_view_platform_interface ^1.0.8 1.0.8 1.0.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
material_color_utilities - 0.8.0 0.8.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
stream_transform - 2.1.0 2.1.0
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.1.0` on google_maps does not support the stable version `7.0.0`, that was published 21 days ago.

When google_maps is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions google_maps to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.