flutter_github_releases_service 0.5.2 icon indicating copy to clipboard operation
flutter_github_releases_service: ^0.5.2 copied to clipboard

Use github releases to update the app.

4
likes
95/ 140
pub points
0%
popularity

We analyzed this package 22 hours ago, and awarded it 95 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:22:61

   ╷
22 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
   │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 38 API elements (34.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_github_releases_service/flutter_github_releases_service.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_github_releases_service/flutter_github_releases_service.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_github_releases_service/flutter_github_releases_service.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_github_releases_service/flutter_github_releases_service.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ajanuw_http^0.6.00.6.00.7.0
flutterflutter0.0.00.0.0
flutter_downloader^1.5.21.10.1+21.10.1+2
install_plugin^2.0.12.0.12.0.1
package_info^2.0.02.0.22.0.2
path^1.8.01.8.31.8.3
path_provider^2.0.12.0.122.0.12
permission_handler^6.1.06.1.310.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.17.01.17.1
ffi-2.0.12.0.1
file-6.1.46.1.4
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.8.0
path_provider_android-2.0.222.0.22
path_provider_foundation-2.1.12.1.1
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
permission_handler_platform_interface-3.9.03.9.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
win32-3.1.34.1.0
xdg_directories-0.2.0+30.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.0` on ajanuw_http does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions ajanuw_http to update the constraint.

The constraint `^6.1.0` on permission_handler does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.