flutter_geopackage 0.6.0+1 icon indicating copy to clipboard operation
flutter_geopackage: ^0.6.0+1 copied to clipboard

A module to support OGC geopackage with sqlite.

2
likes
90/ 140
pub points
66%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 78 out of 435 API elements (17.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_geopackage/flutter_geopackage.dart that imports:
  • package:dart_hydrologis_db/dart_hydrologis_db.dart that imports:
  • package:postgres/postgres.dart that imports:
  • package:postgres/src/substituter.dart that imports:
  • package:postgres/src/query.dart that imports:
  • package:postgres/src/execution_context.dart that imports:
  • package:postgres/src/connection.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

INFO: The variable name 'DEFAULT_GEOM_FACTORY' isn't a lowerCamelCase identifier.

lib/com/hydrologis/flutter_geopackage/core/geom.dart:150:32

    ╷
150 │   static final GeometryFactory DEFAULT_GEOM_FACTORY =
    │                                ^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/com/hydrologis/flutter_geopackage/core/geom.dart

INFO: The value of the local variable 'b1' isn't used.

lib/com/hydrologis/flutter_geopackage/core/geom.dart:238:9

    ╷
238 │     var b1 = _din.readByte();
    │         ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/com/hydrologis/flutter_geopackage/core/geom.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_hydrologis_db^1.0.01.0.0+11.0.0+1
dart_jts^0.2.20.2.2+30.2.2+3
intl>=0.16.1 <=0.17.00.17.00.18.0
proj4dart^2.0.02.1.02.1.0
sqlite3^1.8.01.9.11.9.1
Transitive dependencies
PackageConstraintCompatibleLatest
buffer-1.2.01.2.0
clock-1.1.11.1.1
collection-1.17.11.17.1
crypto-3.0.23.0.2
ffi-2.0.12.0.1
js-0.6.70.6.7
lists-1.0.11.0.1
meta-1.9.01.9.0
mgrs_dart-2.0.02.0.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
postgres-2.5.22.5.2
sasl_scram-0.1.10.1.1
saslprep-1.0.21.0.2
stack_trace-1.11.01.11.0
typed_data-1.3.11.3.1
unicode-0.3.10.3.1
unorm_dart-0.2.00.2.0
wkt_parser-2.0.02.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.16.1 <=0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.