flutter_geopackage 0.0.1

  • Readme
  • Example
  • Installing
  • new35

flutter_geopackage #

A module to support OGC geopackage with sqlite.

At the moment, the vector (features) part of geopackage is supported.

View the example README for instructions on how to integrate it in an app.

example/README.md

example #

Geopackage Example App

VERY IMPORTANT REGARDING THE EXAMPLE APP #

The example app works only on Android due to its dependence on the storage path of the test geopackage database. IOS users will need to change the path from which the geopackage database is pulled. No big issue, but it is not automatic yet (pull requests are welcome, I don't really care about IOS at the time being, so it might take a while before I do it).

For the example to work, you need to copy the gdal_sample.gpkg file that is in the test folder of the main library (flutter_geopackage) to the main storage of the device, i.e. it has to be available in /storage/emulated/0/gdal_sample.gpkg since the path is hardcoded (see above comment).

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_geopackage: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_geopackage/flutter_geopackage.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
80
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
57
Overall:
Weighted score of the above. [more]
35
Learn more about scoring.

We analyzed this package on Dec 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.2

Health suggestions

Fix lib/com/hydrologis/flutter_geopackage/core/utils.dart. (-9.08 points)

Analysis of lib/com/hydrologis/flutter_geopackage/core/utils.dart reported 19 hints, including:

line 11 col 1: Prefer using /// for doc comments.

line 19 col 3: Prefer using /// for doc comments.

line 24 col 3: Prefer using /// for doc comments.

line 29 col 3: Prefer using /// for doc comments.

line 34 col 3: Prefer using /// for doc comments.

Fix lib/com/hydrologis/flutter_geopackage/geopackage.dart. (-8.63 points)

Analysis of lib/com/hydrologis/flutter_geopackage/geopackage.dart reported 18 hints, including:

line 7 col 23: Name non-constant identifiers using lowerCamelCase.

line 9 col 23: Name non-constant identifiers using lowerCamelCase.

line 11 col 23: Name non-constant identifiers using lowerCamelCase.

line 13 col 23: Name non-constant identifiers using lowerCamelCase.

line 15 col 23: Name non-constant identifiers using lowerCamelCase.

Fix lib/com/hydrologis/flutter_geopackage/core/geom.dart. (-1.99 points)

Analysis of lib/com/hydrologis/flutter_geopackage/core/geom.dart reported 4 hints:

line 154 col 32: Name non-constant identifiers using lowerCamelCase.

line 244 col 9: The value of the local variable 'b1' isn't used.

line 245 col 9: The value of the local variable 'b2' isn't used.

line 246 col 9: The value of the local variable 'b3' isn't used.

Fix lib/flutter_geopackage.dart. (-1.49 points)

Analysis of lib/flutter_geopackage.dart reported 3 hints:

line 4 col 8: Unused import: 'dart:collection'.

line 8 col 8: Unused import: 'dart:math'.

line 11 col 8: Duplicate import.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cupertino_icons ^0.1.2 0.1.3
dart_jts ^0.0.4+2 0.0.4+2
flutter 0.0.0
intl ^0.16.0 0.16.0
sqflite ^1.1.7+2 1.1.8
Transitive dependencies
collection 1.14.11 1.14.12
hex 0.1.2
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
synchronized 2.1.1
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
pedantic ^1.8.0+1
test any