flutter_gen_runner 5.4.0 copy "flutter_gen_runner: ^5.4.0" to clipboard
flutter_gen_runner: ^5.4.0 copied to clipboard

The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.

196
likes
140/ 140
pub points
97%
popularity

We analyzed this package 37 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/FlutterGen/flutter_gen/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 7 API elements (28.6 %) have documentation comments.

Some symbols that are missing documentation: flutter_gen_runner, flutter_gen_runner.FlutterGenBuilder, flutter_gen_runner.FlutterGenBuilder.FlutterGenBuilder, flutter_gen_runner.FlutterGenBuilder.generator, flutter_gen_runner.build.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_gen_runner/flutter_gen_runner.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
build ^2.0.0 2.4.1 2.4.1
collection ^1.17.0 1.18.0 1.18.0
crypto ^3.0.0 3.0.3 3.0.3
flutter_gen_core 5.4.0 5.4.0 5.4.0
glob ^2.0.0 2.1.2 2.1.2
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
color - 3.0.0 3.0.0
convert - 3.1.1 3.1.1
dart_style - 2.3.6 2.3.6
dartx - 1.2.0 1.2.0
file - 7.0.0 7.0.0
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
meta - 1.12.0 1.12.0
mime - 1.0.5 1.0.5
package_config - 2.1.0 2.1.0
petitparser - 6.0.2 6.0.2
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
time - 2.1.4 2.1.4
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
xml - 6.5.0 6.5.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

196
likes
140
pub points
97%
popularity

Publisher

verified publisherwasabeef.jp

The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.

Repository (GitHub)
View/report issues
Contributing

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

build, collection, crypto, flutter_gen_core, glob, path

More

Packages that depend on flutter_gen_runner