flutter_gen_linter 1.0.0+2 copy "flutter_gen_linter: ^1.0.0+2" to clipboard
flutter_gen_linter: ^1.0.0+2 copied to clipboard

A set of simple linter rules to encourage the use of flutter_gen.

0
likes
140/ 160
pub points
0%
popularity

We analyzed this package 7 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 13 API elements (69.2 %) have documentation comments.

Some symbols that are missing documentation: flutter_gen_linter, flutter_gen_linter.AvoidAssetImage, flutter_gen_linter.AvoidAssetImage.AvoidAssetImage, flutter_gen_linter.createPlugin.

0/10 points: Package has an example and has no issues with screenshots

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:flutter_gen_linter/flutter_gen_linter.dart that imports:
  • package:custom_lint_builder/custom_lint_builder.dart that imports:
  • package:custom_lint_core/custom_lint_core.dart that imports:
  • package:custom_lint_core/src/type_checker.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/error/error_code_values.g.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/dart/ast/extensions.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/resolver.dart that imports:
  • package:analyzer/src/generated/static_type_analyzer.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inference_helper.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inferrer.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/well_bounded.dart that imports:
  • package:analyzer/src/dart/element/type_algebra.dart that imports:
  • package:analyzer/src/summary2/record_type_builder.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/link.dart that imports:
  • package:analyzer/src/summary2/top_level_inference.dart that imports:
  • package:analyzer/src/task/strong_mode.dart that imports:
  • package:analyzer/src/dart/element/inheritance_manager3.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:analyzer/src/file_system/file_system.dart that imports:
  • package:analyzer/src/util/uri.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=4.7.0 <6.0.0 5.13.0 6.8.0
analyzer_plugin ^0.11.2 0.11.2 0.11.3
custom_lint ^0.5.0 0.5.11 0.6.4
custom_lint_builder ^0.5.0 0.5.14 0.6.4
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 73.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
checked_yaml - 2.0.3 2.0.3
ci - 0.1.0 0.1.0
cli_util - 0.4.1 0.4.1
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
custom_lint_core - 0.5.14 0.6.3
dart_style - 2.3.2 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
freezed_annotation - 2.4.4 2.4.4
glob - 2.1.2 2.1.2
hotreloader - 4.2.0 4.2.0
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
rxdart - 0.27.7 0.28.0
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.3 0.7.3
typed_data - 1.3.2 1.3.2
uuid - 4.4.2 4.4.2
vm_service - 14.2.4 14.2.4
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=4.7.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.5.0` on custom_lint does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions custom_lint to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

0
likes
140
pub points
0%
popularity
screenshot

Publisher

verified publisherbramp.net

A set of simple linter rules to encourage the use of flutter_gen.

Repository (GitHub)
View/report issues

Topics

#lints

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

analyzer, analyzer_plugin, custom_lint, custom_lint_builder

More

Packages that depend on flutter_gen_linter