flutter_gen 1.3.1
flutter_gen: ^1.3.1 copied to clipboard

Dart native
Flutter Android iOS

The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.

50
likes
100 / 110
pub points
84 %
popularity

We analyzed this package on Jan 17, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 6 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_gen/build.dart that imports:
  • package:flutter_gen/src/flutter_generator.dart that imports:
  • package:flutter_gen/src/utils/file.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.01.6.0
build^1.3.01.6.11.6.1
color^2.1.12.1.12.1.1
dart_style^1.3.61.3.111.3.11
dartx^0.5.00.5.00.5.0
mime^0.9.70.9.70.9.7
path^1.7.01.7.01.7.0
xml^4.2.04.5.14.5.1
yaml^2.2.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.014.0.0
analyzer-0.41.20.41.2
async-2.4.22.4.2
characters-1.0.01.0.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
file-5.2.15.2.1
glob-1.2.01.2.0
intl-0.16.10.16.1
js-0.6.20.6.2
logging-0.11.40.11.4
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
time-1.4.01.4.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

50
likes
100
pub points
84%
popularity

Publisher

wasabeef.jp

The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

args, build, color, dart_style, dartx, mime, path, xml, yaml

More

Packages that depend on flutter_gen